Написать программу находящую сумму всех трехзначных чисел, в записи которых есть четные цифры

meduzakoy4kla meduzakoy4kla    2   10.03.2019 07:20    3

Ответы
interpol7772 interpol7772  24.05.2020 15:07

var a,b,c,d,j:integer;
begin
j:=0;
for a:=100 to 112 do
begin
b:=a div 10;
d:=a mod 10;
c:=a-(100*b)-d;
if (a div 2=a/2) or (b div 2=b/2) or (c div 2=c/2) then j:=j+1;
end;
writeln(j);
end.

это для pascalABC 

 
ПОКАЗАТЬ ОТВЕТЫ
АлсушкаСушка АлсушкаСушка  24.05.2020 15:07

Program n1;
Uses CRT;
Var a,b,c,s,i: integer;
begin
ClrScr;
For i:=100 to 999 do
begin
a:=i div 100;
b:=i mod 100 div 10;
c:=i mod 10;
If (a mod 2=0)or(b mod 2=0)or(c mod 2=0) then s:=s+i;
end;
writeln('summa ravna ',s);
readln
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика