Написать программу на заполнение 2-х массивов(рост девочек и рост мальчиков).определить средний рост мальчиков.подсчитать количество девочек,у которых рост выше среднего роста мальчиков.

Nicoleta23 Nicoleta23    3   10.03.2019 01:00    1

Ответы
kauymovemil kauymovemil  24.05.2020 13:12

unit math;

var

   d,m:array[1..20] of integer;

   sr:real;

   kol,s:integer;

Begin

  for i:=1 to 20 do begin

    d[i]:=RandomRange(140,180);

    writeln('Рост ',i,'-ой девочки =',d[i],' см');

    m[i]:=RandomRange(140,190);

    writeln('Рост ',i,'-го мальчика= ',m[i],' см');

  end;

 s:=0;sr:=0;kol:=0;

 for i:=1 to 20 do s:=s+m[i];

 sr:=s/20;

 writeln('Средний рост мальчиков= ',sr,' см');

 for i:=1 to 20 do

  if d[i]>sr then kol:=kol+1;

 writeln('Колличество девочек превышающий средний рост мальчиков= ',kol);

End.

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика