Написать программу на языке си++ вычислить сумму ряда до 20 члена s=)*(k! +1)*x^k)/3^k

alesqwer alesqwer    1   15.07.2019 23:00    2

Ответы
mintoo0 mintoo0  03.10.2020 05:07
Исходя из вашего запроса:
без отрицания k
#include <iostream>
using namespace std;
int main()
{   
int a,k,s,x;
 for (k=0; k<20; k++)
{       
s +=((-1)*(k+1)*x^k)/3^k;   
}   
cout << s << endl;   
system("pause"); // или _getch();
return 0;
}

с отрицанием k
#include <iostream>
using namespace std;
int main()
{   
int a,k,s,x;   
for (k=0; k<20; k++)   
{       
s +=((-1)*(k+1)*x^k)/3^k;   
}   
cout << s << endl;   
system("pause"); // èëè _getch();   
return 0;
}
и формулируйте вопрос корректнее. 
в обоих решениях k=0 изначально
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика