Написать программу на языке си дано число х в 10 системе счисления. перевести его в систему счисления с основанием n

evasoksoksok evasoksoksok    1   27.08.2019 08:50    1

Ответы
Маслинка174 Маслинка174  05.10.2020 22:28
#include<iostream>
#include<string>
using namespace std;

int main()
{
    int x,n;
     string S;
     cout << "x = ",cin >> x;
     cout <<"n = ",cin >> n;
    while(x / n > 0){
        cout <<x / n<<" "<<x % n<<"\n";
        S = (char)(x % n<10?x % n+'0':x % n+'A'-10)+S;
        x = x / n;
        }
    if(x!=0){S = (char)(x<10?x+'0':x+'A'-10)+S;}
    cout <<"x_n = "<<S<<"\n";
     system("Pause");
     return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика