Написать программу на языке с++ : в одной старинной мудрец предложил шаху в качестве награды за услугу выдать зерно. причем количество зерна оговорил так: на первую клетку шахматной доски положить 1 зерно, на 2-ую - 2, на 3-ю - 4, на 4-ую - 8 и т.д. составить программу, с которой можно вычислить, на какой клетке суммарное количество зерен превысит n штук.

Эва637 Эва637    3   08.07.2019 00:20    1

Ответы
bopoh234567 bopoh234567  31.07.2020 01:53
//
//   Разработал GonanSoft
//
int i; 
unsigned long long k=0; // сумма зёрен на i-ом шаге
unsigned long long s=1; // количество зерен в i-ой клетке 
unsigned long long n; // переменная признак окончания

cout << 'количество зерен '; 
cin>>n;
for (i = 1; i <= 64; i++) 
{
  k=k+s;
  if (n<k)
    break;
  s=s<<1; 
}

if (n<>18446744073709551615)  //это проверка на максимум зёрен
  cout << 'Номер клетки = ' << i << '\n';
else
  cout << 'Сумма зёрен не превысит 18446744073709551615  ' << i << '\n';
//
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика