Написать программу на языке с++(со всеми объяснениями )
написать функцию, которая возвращает 1, если число, полученное в качестве аргумента, является простым, и ноль – в противном случае.​

marinadm9889 marinadm9889    1   12.11.2019 06:05    4

Ответы
tim2424 tim2424  10.10.2020 12:35

#include <iostream>

using namespace std;

int F(int n)   // сама функция

{

   if(n<2) return 0; // простые числа начинаются от 2

   if(n==3) return 1; // число 3 - простое

   bool found = (n % 2 == 0); // если число четное, делитель найден

   int p = 3;

   while((!found) && (p*p <= n)) // цикл поиска делителя

   {

       found = (n % p == 0); // найден ли делитель

       p+=2; // следующий делитель для проверки

   }

   return !found;

}

int main()  // тестовая программа

{

   int k;

   cin >> k;   // ввод числа

   cout << "Result: " << F(k); // тестируем функцию

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика