Написать программу на языке с++(со всеми объяснениями )
1. написать функцию, которая принимает в качестве аргументов целочисленный массив и переменную. находит сумму четных и сумму нечетных элементов. в переменную-аргумент сохраняет максимальную из сумм. возвращает минимальную из сумм.​

Sosushka Sosushka    3   19.11.2019 08:41    8

Ответы
nicgames nicgames  10.10.2020 14:12

   int r = minmax(a, b);

   cout << "Сумма min " << r << ", сумма max " << b << endl;

   return 0;

}

По поводу "всех объяснений" - я этого не понимаю. Написать что делает каждый оператор, зачем он тут и почему именно такой - это долгое и бессмысленное занятие, ответ будет объемом в несколько книжных страниц, но все равно толком ничего не даст. Если Вы не умеет программировать - учится надо не по ответу на задачу, а если умеете - никакое описание не нужно.

Единственная заморочка тут - передача длины массива в вызываемую функцию. В С++ с этим беда, потому обычно используют библиотечный класс Vector, где можно узнать длину массива. Вместо массива в С++ при вызове функции передается указатель на его первый элемент, поэтому информацию о длине массива получить нельзя. Так что нужно передавать еще один параметр - длину массива. Но в задании сказано, что параметра всего два и второй служит для получения максимальной из двух сумм. Но это при возвращении результата! Поэтому было принято решение при вызове функции в качестве b передать длину массива.


Написать программу на языке с++(со всеми объяснениями )1. написать функцию, которая принимает в каче
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика