tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на языке с
Написать программу на языке с программа должна считывать последовательность 25 чисел из файла, заменить все элементы, которые меньше среднего арифметического этих элементов, на 0 и вывести новую последовательность в новый файл
захар187
1 15.09.2019 01:50
0
Ответы
5v09
07.10.2020 15:51
#include <stdio.h>
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
maslennikovavi2
14.04.2020 20:19
ХЕЛП БОЙС АНД ГЕРЛС ИНФОРМАТИКА ОЧЕНЬ...
kisa99w934e8
14.04.2020 20:19
Число 1410=11102 в восьмиразрядном представлении имеет вид:...
thesketchyoup081qt
14.04.2020 20:19
Дано число, если оно четное, то разделить его на 2, иначе умножить на три и вывести на экран...
kkkkiiiii
08.05.2020 13:01
Що спільного і чим відрізняється цикл з лічильником і цикл з передумовою...
pollylu12
28.06.2019 04:50
Сколько времени можно проводить за компьютером ребёнку?...
Саша99990
25.05.2020 15:20
Определите, что будет напечатано в результате выполнения программы var c, m, d:Integer; Begin c:=0; m:=132; while m 1 do begin d:=m mod 10; c:= (c+d)*10; m:=m div 10;...
Dima687464376
25.05.2020 15:18
В григорианском календаре года нумерются числами 1, 2, 3 и т.д., это года “нашей эры”. Предшествующие года называются “первый год до нашей эры”, “второй год до нашей эры”...
sergey1234567891011
24.05.2020 14:44
Быстреее !!даны кружка и бидон,найти сколько понадобится кружек,чтобы полностью заполнить бидон(программа с циклом,без операторов div и mod)...
Veid
25.05.2020 15:18
Задача 6: Прожектора На дискотеке в ряд стоят три прожектора, которые поочерёдно светят в следующем порядке: левый, средний, правый, средний, левый, средний, правый, средний...
стас2118
24.05.2020 14:34
решите итоговую по информатике сегодня надо...
Популярные вопросы
Один лист, два листья, один листок, два лист как правильно...
3
Поміркуй, чи можна посудину напонити газом на 50 %. Якщо так, напиши,...
1
Площа земельної ділянки 50га. її 75% засіяли пшеницею. Скільки ділянки...
1
Розвяжіть систему рівнянь у-х=-16; х*у=17...
3
1. Соғыстан кейінгі кезеңде Қазақстанда теміржолдар салынуының себебі...
3
5 Write this information on a piece of paperin a different order.•...
1
Два примера по алгебре за надо очень...
1
Сочинение на тему осень с пословицами и поговорками...
2
Скиньте решение или решите что бы понятно было...
2
Как можно определить, что такое Просвещение?...
2
main()
{
int x, s=0, n=0;
float sr;
FILE *fin, *fout;
fin = fopen("input.txt", "r");
fout = fopen("output.txt", "w");
while (fscanf(fin, "%d", &x) == 1) {
s+=x;
n++;
}
sr = 1.0*s/n;
fclose (fin);
fin = fopen("input.txt", "r");
while (fscanf(fin, "%d", &x) == 1) {
if (x < sr) x = 0;
fprintf (fout, "%d ", x);
}
fclose (fout);
fclose (fin);
}
Пример:
Файл input.txt:
21 45 87 61 90 43 70 15 33 58
Файл output.txt:
0 0 87 61 90 0 70 0 0 58