Написать программу на языке с++, которая вычисляет произведение отрицательных чисел среди четырех заданных. после чего сообщает - является ли полученное произведение отрицательным или положительным

Nikitoskin102 Nikitoskin102    3   22.10.2019 11:59    4

Ответы
yulyatimonen yulyatimonen  10.10.2020 08:41

#include <iostream>

using namespace std;

int main()

{

 int a[4];

 int i, p;

 setlocale(LC_ALL, "russian");

 cout << "Введите четыре числа: ";

 for (i = 0; i < 4; i++) {

   cin >> a[i];

 }

 p = 1;

 for (i = 0; i < 4; i++) {

   p *= a[i];

 }

 if (p > 0)

   cout << "\nПроизведение положительно";

 else if (p < 0)

   cout << "\nПроизведение отрицательно";

 else

   cout << "\nПроизведение равно 0";

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика