Написать программу на языке с++. дано натурально число а в десятичной системе счисления. если все цифры числа а различные, то вывести на экран сообщение "да", иначе - сообщение "нет".

sunnyAkhhhh sunnyAkhhhh    3   11.08.2019 11:40    1

Ответы
elf35 elf35  04.10.2020 11:13
#include <iostream>
using namespace std;

int main()
{
    int a;
    int k[9];
    bool f = true;
    cout << "a = ", cin >> a, cout << "\n";
    for (int i=0; i<10; i++) k[i]=0;
    while (a>0){
    k[a % 10]++;
    a = a / 10;
    }
    for (int i=0; i<10; i++){
    if (k[i]>1) f = false;
    }
    if (f) cout << "Да" << "\n";
    else cout << "Нет" << "\n";
    return 0;
}

Пример:
a = 12523
Нет
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика