Написать программу на языке python

F(n)=1 при n=1

F(n)=n+F(n-1), если n чётно,

F(n)=2*F(n-2), если n>1 и нечётно

Вывести F(25)

arinaschool1 arinaschool1    1   18.09.2021 19:10    2

Ответы
NastiaForever18 NastiaForever18  18.09.2021 19:20

def F(n):

 if n == 1:

   return 1

 elif n % 2 == 0:

   return n + F(n-1)

 elif n % 2 != 0:

   return 2*F(n-2)

 

print(F(25))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика