Написать программу на языке программирования Паскаль: Автобусный билет считают счастливым, если сумма трех первых цифр билета равна сумме трех последних цифр.

BektasB BektasB    2   16.02.2021 19:06    2

Ответы
grimm330066Flippoo grimm330066Flippoo  16.02.2021 19:10

Программа:

var n,a1,a2,s1,s2:integer;

begin

write('n = '); readln(n);

a1:=n div 1000;

s1:=(a1 div 100)+(a1 div 10 mod 10)+(a1 mod 10);

a2:=n mod 1000;

s2:=(a2 div 100)+(a2 div 10 mod 10)+(a2 mod 10);

if s1=s2 then writeln('Билет счастливый')

          else writeln('Билет не счастливый')

end.

Пример:

n = 123231

Билет счастливый

Блок-схема - в прилагаемом файле.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика