Написать программу на языке паскаля дан одномерный массив целых чисел, состоящий из 22 элементов, посчитать количество отрицательных элементов массива, а также количество элементов которые делятся на 9.

zhenya4534 zhenya4534    1   12.07.2019 14:30    3

Ответы
VovaUtyuzh VovaUtyuzh  18.09.2020 13:52
Var
a:array[1..100] of integer;
s,s1,i:integer;
begin
for i:=1 to 22 do
begin
a[i]:=random(10)-10;
if a[i]<0 then
begin
s:=s+1;
end;
if a[i] mod 9=0 then
begin
s1:=s1+1;
end;
end;
writeln(s,s1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Карина2000017 Карина2000017  18.09.2020 13:52
Var i,k1,k2:integer;
begin;
var ar:=ArrRandomInteger(23,-50,50);
for i:=1 to 22 do
begin;
write(ar[i]:4);
if ar[i]<0 then inc(k1);
if ar[i] mod 9=0 then inc(k2);
 end;
writeln;
writeln('Отрицательные:',k1);
write('Делятся на 9:',k2);
end.

//Неинтересный вариант
var i,k1,k2:integer;
ar:array[1..22] of integer;
begin;
for i:=1 to 22 do
begin;
ar[i]:=random(100)-50;
write(ar[i]:4);
if ar[i]<0 then inc(k1);
if ar[i] mod 9=0 then inc(k2);
end;
writeln;
writeln('Отрицательные:',k1);
write('Делятся на 9:',k2);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика