Написать программу на языке паскаль уровень b. заполнить массив случайными числами в интервале [0,100] и отобрать в другой массив все простые числа. используйте логическую функцию, которая определяет, является ли переданное ей число простым. пример: массив а: 12 13 85 96 47 массив b: 13 47

елена13333 елена13333    1   17.07.2019 18:10    121

Ответы
vikaMiwka vikaMiwka  21.09.2020 19:21
Const 
n=5;

Var
 ar:array[1..n] of integer;
 ar2:array[1..n] of integer;
 i,k:integer;

 function prost(a:integer):boolean;
 var i:integer;
 b:boolean;
  begin
  b:=true;
   for i:=2 to a div 2 do
    if a mod i=0 then
     begin;
      b:=false;
      break;
     end;
   if a=1 then b:=false;
  prost:=b;
 end;

  begin;
 randomize;
 k:=0;
  for i:=1 to n do
   begin;
    ar[i]:=random(101);
    write(ar[i]:4);
   end;
  writeln;
  for i:=1 to n do
  if prost(ar[i]) then
   begin;
    inc(k);
    ar2[k]:=ar[i];
    write(ar2[k]:4);
   end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика