Написать программу на языке паскаль (разветвляющийся алгоритм): 1) f=x2-3 (икс в квадрате минус три), x2=x*x (x в квадрате равен x умножить на x) 2) s=1/2ab (одна вторая а б) 3) с=a2-b2 (а в квадрате минус б в квадрате)

ЖанЖак2003 ЖанЖак2003    1   04.06.2019 14:10    4

Ответы
ffhbcdfhj ffhbcdfhj  05.07.2020 13:53
Var x,f,s,c,a,b:real;
begin
write('X = ');
readln(x);
write('A = ');
readln(a);
write('B = ');
readln(b);
f:=x*x-3;
s:=a*b/2;
c:=a*a-b*b;
writeln('F=',f:3:2,' S=',s:3:2,' C=',c:3:2);
end.
ПОКАЗАТЬ ОТВЕТЫ
eleukenovadinara eleukenovadinara  05.07.2020 13:53
1) Не разветвление)
program xizt;
uses crt;
var x,f:real;
begin
 writeln ('введите х');
readln (x);
f:=sqr(x)-3;
writeln (f);
end.
2) program xizt;
uses crt;
var a,b,s:real;
begin
 writeln ('введите a,b через пробел');
readln (a,b);
s:=1/2*a*b
writeln (s);
end.
3) program xizt;
uses crt;
var a,b,c:real;
begin
 writeln ('введите a,b через');
readln (a,b);
c:=sqr(a)-sqr(b);
writeln (c);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика