Написать программу На языке Паскаль
программа должна из введенного массива на 10 элементов, находить и выводить на экран минимальный и максимальный элемент, а так же сумму всех элементов массива.

Elirgon88 Elirgon88    1   07.04.2020 23:33    0

Ответы
cudak cudak  12.10.2020 22:07

Program zadacha;

const n=10;

var

a:array [1..n] of integer;

i,min,max,sum:integer;

begin

 writeln('Введите элементы:');

 for i := 1 to n do read(a[i]);;

 

 max:=-10000; min:=10000;

 

 for i:=i to n do

   if (a[i]>max) then max := a[i];

   writeln('Максимальное число в массиве: ',max);

   

  for i:=1 to n do

    if (a[i]<min) then min:=a[i];

    writeln('Минимальное число в массиве: ',min);

 

 for i := 1 to n do sum:=sum+a[i];

 writeln('Сумма всех чисел массива = ',sum);

End.

Объяснение:

min ставим наибольшим, чтобы оно постепенно уменьшалось в сравнении. max ставим от наименьшего, чтобы оно увеличивалось в сравнении.

При суммировании необязательно обнулять переменную (в данном случае sum), т.к. у нас немного действий.


Написать программу На языке Паскаль программа должна из введенного массива на 10 элементов, находить
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика