Написать программу на языке паскаль: гражданин 1 марта открыл счет в банке, вложив 1000 руб. через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. опре-делить : а) за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.; б) через сколько месяцев размер вклада превысит 1200 руб.

yjsts yjsts    3   24.08.2019 23:10    2

Ответы
Юриякамория Юриякамория  05.10.2020 17:34
Var s,ds:real; k1,k2:integer;
begin
//a
s:=1000; ds:=0; k1:=0;
while ds<=30 do
 begin
 ds:=s*0.02;
 s:=s+ds;
 k1:=k1+1;
 end;
writeln('k1 = ',k1);
//б
s:=1000; ds:=0; k2:=0;
while s<=1200 do
 begin
 s:=1.02*s;
 k2:=k2+1;
 end;
writeln('k2 = ',k2);
end.

Результат:
k1 = 22
k2 = 10
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика