Написать программу на языке паскаль. если можно, объясните , что за переменные там используются дана матрица а[8,8] четных чисел натурального ряда (от 2 до 64). 1)заполнить и записать матрицу. 2)определит число элементов меньших 18 и больших 60,заменить их на 0,затем записать получившуюся матрицу. 3)определить произведение главной диагонали и вывести эти элементы на экран. 4)реализовать определение суммы элементов любого столбца.

Prinsess1 Prinsess1    2   07.07.2019 17:30    3

Ответы
missvaleria2 missvaleria2  30.07.2020 21:51
Var
a:array[1..8,1..8] of integer;{матрица}
i,i1,b,sum,st:integer;{первые 2 переменные для циклов,b - для заполнения матрицы, sum - для нахождения суммы чисел}
begin
  for i:=1 to 8 do begin
    for i1:=1 to 8 do begin
      b:=b+1;
      if b mod 2 = 0 then a[i,i1]:=b else a[i,i1]:=b+1;
      if a[i,i1] > 60 then write(0:3) else if a[i,i1] < 18 then write(0:3) else write(a[i,i1]:3);
     
    end;
    writeln;
  end;
  writeln('Главная диагональ');
  sum:=1;
  for i:=1 to 8 do begin
    sum:=sum*a[i,i];
    writeln(a[i,i]:i*2);
  end;
  writeln('Сумма - ',sum);
  write('Введите номер столбца - ');
  readln(st);
  sum:=0;
  for i:=1 to 8 do sum:=sum+a[i,st];
  writeln('Сумма чисел этого столбца - ',sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика