Написать программу на языке паскаль. даны три действительные числа. сложить те из них, значения которых не отрицательны.

turarernur turarernur    1   23.06.2019 07:30    12

Ответы
Geniud Geniud  19.07.2020 09:17
Program chisl;
var a,b,c,d:integer;
begin
write('Введите a = ' );
readln(a);
if a>=0 then d:=d+a;
write('Введите b = ' );
readln(b);
if b>=0 then d:=d+b;
write('Введите c = ' );
readln(c);
if c>=0 then d:=d+c;
writeln(d);
end.
ПОКАЗАТЬ ОТВЕТЫ
87015148669 87015148669  19.07.2020 09:17
Var a, b, c, rez: real;
begin
write('Введите число А: ');
readln(a);
write('Введите число B: ');
readln(b);
write('Введите число C: ');
readln(c);
if (a >= 0) and (b >= 0) and (c >= 0) then rez := a + b + c;
if (a >= 0) and (b >= 0) then rez := a + b;
if (a >= 0) and (c >= 0) then rez := a + c;
if (b >= 0) and (c >= 0) then rez := b + c;
if (a <= 0) and (b <= 0) then rez := c;
if (b <= 0) and (c <= 0) then rez := a;
if (a <= 0) and (c <= 0) then rez := b;
if (a <= 0) and (b <= 0) and (c <= 0) then rez := 0;
writeln(rez);
end.

Громоздко, но, думаю, покатит
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика