Написать программу на языке паскаль . дан одновременный массив из п целых чисел .составить программу вычисления суммы элементов стоящих на четных местах

Wikwsejjj Wikwsejjj    2   30.03.2019 16:10    6

Ответы
КириллSOS КириллSOS  27.05.2020 17:58

var

M:array[0..100]of integer;

i,k,n:integer;

begin

k:=0

randomize;

write('введите кол-во элементов массива');

read(n);

for i:=1 to n do

begin

M[i]:=random (30);

if i mod 2 =0 then k:=k+M[i]

else write ('Четных элементов нет');

writeln ('Сумма четных элементов', k);

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
maximpopov2001 maximpopov2001  27.05.2020 17:58

var

  a : array [1..1000] of integer;

  i, n, sum : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  sum := 0;

  for i := 1 to n do

    if i mod 2 = 0 then inc (sum, a[i]);

  writeln (sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика