Написать программу на языке pascalabc, которая умеет выполнять арифметические действия с 5 разными числами и выводит промежуточные и итоговый результаты. пример работы программы: введите первое число: 4 выберите первое действие (a) сложить, b) вычесть, c) умножить, d) разделить): a введите второе число: 8 первая операция: 4+8=12 введите второе действие (a) сложить, b) вычесть, c) умножить, d) разделить): c введите третье число: 3 вторая операция: 12*3=26 так до пятого числа и 5 операции

Gagoro Gagoro    3   18.09.2019 03:20    4

Ответы
mirgin2002 mirgin2002  07.10.2020 23:09
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=Arr('первое', 'второе','третье','четвертое','пятое');
  var p,r:real;
  var c:char;
  Write('Введите первое число: '); Readln(r);
  for var i:=0 to 3 do begin
    Write('Выберите ',s[i], ' действие (a) сложить, b) вычесть,');
    Write('c) умножить, d) разделить): '); Readln(c);
    Write('Введите ',s[i+1],' число: '); Readln(p);
    case c of
    'a':r+=p;
    'b':r-=p;
    'c':r*=p;
    'd':r/=p;
      end;
    Writeln('Результат: ',r)
    end
end.

Написать программу на языке pascalabc, которая умеет выполнять арифметические действия с 5 разными ч
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика