Написать программу на языке pascal палиндромом называется строка, которая одинаково читается как слева направо, так и справа налево. рассмотрим все натуральные числа, запись которых в десятичной системе счисления является палиндромом (при этом запись не начинается с нуля). например, числа 121 и 1331 являются палиндромами, а число 123 — нет. по данному числу n найдите n-e в порядке возрастания число-палиндром. программа получает на вход одно натуральное число n, не превосходящее 100 000. программа должна вывести одно натуральное число — n-е в порядке возрастания число-палиндром. пример входных и выходных данных ввод 20 вывод 111

Abdulla2009 Abdulla2009    1   07.08.2019 22:30    4

Ответы
kauymbek kauymbek  04.10.2020 03:55
Var
  s: string;
  n,m: integer;

 begin
  readln(n);
  if (n <= 9) then write(n)
  else if (n <= 9 + 9) then
     begin
       s := inttostr(n - 9);
      write(s + s);
     end
  else if (n <= 9 + 9 + 90) then
     begin
       s := inttostr(n - 9 -9 + 10 -1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90) then
     begin
       s := inttostr(n - 9 - 9 + 90 + 10 - 1);
       write(s + s[::-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 + 100 - 1);
       m:=s.Length-1;
write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 + 100 - 1);
       write(s + s[::-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 + 1000 - 1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
  else if (n <= 9 + 9 + 90 + 90 + 900 + 900 + 9000 + 9000) then
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 + 1000 - 1 );
       write(s + s[::-1]);
     end
  else
     begin
       s := inttostr(n - 9 - 9 - 90 - 90 - 900 - 900 - 9000 - 9000 + 10000 - 1);
       m:=s.Length-1;
       write(s + s[m:0:-1]);
     end
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика