Написать программу на языке Pascal.ABC задача1
даны катеты прмоугольного треугольника а и b. найти его гипотенузу с, периметр Р и площадь S
задача2
найти длину окружности L и площадь круга S заданного радиуса R. (L=2пR; S=пR^2; считать, что п =3,14) ​

дстмсдрлпоа дстмсдрлпоа    1   13.11.2020 22:49    2

Ответы
лис239 лис239  13.12.2020 22:50

1)

program tr;

var a,b,c,S,P:double;

begin

write('Введите 2 катеты: ');

read(a);

read(b);

c:=Sqrt((a*a)+(b*b));

writeln('Гипотенуза -',c:6:2);

P:=a+b+c;

writeln('Периметр - ',P:6:2);

S:=(a*b)/2;

writeln('Площадь - ',S:6:2);

end.

2)

program kr;

var a,b,c,S,PI,L,R:double;

begin

PI:=3.14;

write('Введите радиус: ');

read(R);

L:=2*PI*R;

writeln('Периметр - ',L:6:2);

S:=PI*Sqr(R);

writeln('Площадь - ',S:6:2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика