Написать программу на языке c++ с процедур
напишите процедуру, которая выводит на экран запись переданного ей числа в
римской системе счисления.
введите натуральное число:
mmxiii
буду

artem705 artem705    3   11.02.2020 13:28    26

Ответы
vikbyk vikbyk  11.10.2020 04:13

Дак это уже было написано тысячу раз...

static void Rom(int N) {

string out="";

string rom[] = { "M", "CM", "D", "CD", "C", "XC", "L", "XL", "X", "IX", "V", "IV", "I" };

int dec[] = { 1000, 900, 500, 400, 100, 90, 50, 40, 10, 9, 5, 4, 1 };

while (N > 0) {

   int i = 0;

   while (N < dec[i]) i++;

   out+=rom[i];

   N -= dec[i];

}

cout << out;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика