tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу на языке
Написать программу на языке c++. перевести с рекурсивной функции conv (n, p) за- данное натуральное число n в p-ичную систему счисления (2 ≤ р ≤ 9).
zhukovaalisa401
2 24.07.2019 16:50
12
Ответы
tana2811
03.10.2020 11:59
#include <iostream>
using namespace std;
void conv(int n, int p) {
if(n/p!=0){
conv(n/p,p);
}
cout << n%p;
}
int main()
{
int n, p;
string m;
cout << "Введите n:", cin >> n, cout << "\n";
cout << "Введите p:", cin >> p, cout << "\n";
conv(n,p);
return 0;
}
Пример:
Введите n: 511
Введите p: 8
777
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
DaNKoLaB
27.09.2020 10:51
Процессордың қандай сипаттамасы туралы айтылған? процессормен бір секундта орындалатын опер цпен (МГц) немесе гигагерцпен (ГГц) өлшенетін Кэш-жады Разрядтылық, Тактілік жиілік...
tanro1
27.09.2020 10:52
ответьте очень Кто первый правильно сделает,сделаю ответ лучшим( за ответ+лучший ответ)...
mkashkan
27.09.2020 10:55
Напишите эссе на тему Техника через 100 лет . Минимум 125 слов....
Babl11
10.06.2019 09:00
10 предложений зачем нужно изучать информатику...
Дубой
10.06.2019 09:00
Какое наибольшее число количество различных цветов можно закодировать используя 8 бит дайте решение заранее !...
Aliiev19
10.06.2019 09:00
Назовите имена нескольких объектов используемых для хранения информации...
666223
10.06.2019 09:00
Текст, число, схема, рисунок, фотография - виды данных?...
babkaaalina
10.06.2019 09:00
Что можно делать в кабинете информатики, а что нельзя делать (правила поведения ) 6-7 предложений...
1000Умник
10.06.2019 08:50
Пример кодирования информации по типу азбуки морзе...
Шуранька
10.06.2019 08:50
Что общего у принтера,монитора и клавиатуры?...
Популярные вопросы
Фонетический разбор слов путь,моль,тень,пальто. вот так надо и всё:Тень[тэн`]надеюсь...
1
Работа в группах.2 1.Сформулируйте 3 «толстых»вопроса ко 2-й части стихотворения....
2
Когда соломенная кровля мельницы с осенявшими её вётлами скрылась за горою,...
1
Бабалар мұрасы 43-сабақ Дауылпаз 1. Сурет бойынша қысқаша мәтін жаз. . Плз...
3
Розгадайте ребуси й складіть тематичні речення зі словами-відповідями....
3
В яку пору року обертальна швидкість найменша...
1
Биография о себе на казахском (примерно)...
2
Какой жанр? Не плачь, не плачь, моё дитя, Не стоит он безумной муки. Верь,...
3
Выполните упражнения по тексту Скину 300 р на счёт Ex. 18. Write an imaginary...
2
Итоги столетней войны? в кратце желательно...
2
using namespace std;
void conv(int n, int p) {
if(n/p!=0){
conv(n/p,p);
}
cout << n%p;
}
int main()
{
int n, p;
string m;
cout << "Введите n:", cin >> n, cout << "\n";
cout << "Введите p:", cin >> p, cout << "\n";
conv(n,p);
return 0;
}
Пример:
Введите n: 511
Введите p: 8
777