Написать программу на языке c++, которая создает и выводит 2x2 квадратную матрицу на экран. после того как матрица появилась на экране, программа должна посчитать её определитель.

sv5080 sv5080    2   26.09.2019 20:50    1

Ответы
oljkejik oljkejik  08.10.2020 21:05
#include <iostream>
#include <time.h>
using namespace std;
int main() {
 setlocale(0, "RUS");
 srand(time(NULL));
 int matr[2][2];
 cout << "Сгенерированная матрица:" << endl;
 for (int i = 0; i < 2; i++) {
  for (int j = 0; j < 2; j++) {
   matr[i][j] = rand() % 10;
   cout << matr[i][j] << " ";
  }
  cout << endl;
 }
cout << "Определитель матрицы: " << matr[0][0] * matr[1][1] - matr[0][1] * matr[1][0] << endl;
system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
alyapareczkaya alyapareczkaya  08.10.2020 21:05
#include <iostream>
#include <vector>
int main()
{
    std::vector<std::vector<size_t>> v2d = { { 5, 4 }, { 3, 5 } };
    for (const auto& i : v2d)
        for (const auto& j : i)
            std::cout << j;
    std::cout << v2d.at(0).at(0) * v2d.at(1).at(1) - v2d.at(0).at(1) *
v2d.at(1).at(0);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика