Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x< -10 и b неравно 0; (x/(x- при x> 0 и b=0; -(|x|*x^2)/c в остальных случаях}

adekvat3 adekvat3    2   28.09.2019 00:10    3

Ответы
lol1045 lol1045  16.08.2020 23:51

#include <iostream>

#include <iomanip>

#include <cmath>


int main()

{

float

 a, b, c, x,

 f = 0.0f;

std::cout << "Введите значения переменных A, B, C, X: ";

std::cin >> a >> b >> c >> x;


if(x < - 10 && b != 0)

 f = -a * pow(x, 2) + pow(b, 3);

else if(x > 0 && b == 0)

 f = x / ((x-c) - a);

else f = -(abs(x) * pow(x, 2)) / c;


std::cout << "Значение переменной f = " << std::setprecision(3) << f << std::endl;

}

g++ compiler

В общем, я не знал, как сохранить блок-схему в фотку, поэтому держи так. Просто срисуй, если нужно. Уж извиняй :)


Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x<
Написать программу на языке c++ и создать блок-схему для следующей функции: f={-a*x^2+b^3 при x<
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика