Написать программу на языке c++. дано четырёхзначное число. поменять в нем число дестков и число тысяч. найти наибольшую и наименьшую цифру. определить - делится ли это число на 2? на 7? на 123? подсчитать число четных цифр.

Dvoeschnick Dvoeschnick    3   24.03.2019 17:48    9

Ответы
Владимирович11 Владимирович11  26.05.2020 16:49

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

   int n, a, b, c, d, e, f, k=0;

   cin >> n;

   a=n%10;

   b=n%100/10;

   c=n%1000/100;

   d=n/1000;

   e=n-d*1000-b*10+d*10+b*1000;

   cout<<e<<endl;

   if (a%2==0)++k; if (b%2==0)++k; if (c%2==0)++k; if (d%2==0)++k;

   f=a; if (b<f) f=b; if (c<f) f=c; if (d<f) f=d;

   if (b>a) a=b; if (c>a) a=c; if (d>a) a=d;

   cout<<"Наименьшая цифра числа "<<f<<endl<<"Наибольшая цифра числа "<<a<<endl;

   if (n%2==0)cout<<"Число делится на 2"<<endl;

   else cout<<"Число не делится на 2"<<endl;

   if (n%7==0)cout<<"Число делится на 7"<<endl;

   else cout<<"Число не делится на 7"<<endl;

   if (n%123==0)cout<<"Число делится на 123"<<endl;

   else cout<<"Число не делится на 123"<<endl;

   cout<<"Число четных цифр в числе равно "<<k<<endl;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика