Написать программу на языке C++ (c#) которая вводит целое чило n и массив из n целых чисел и определяет есть ли в массиве число 30.

wsmol wsmol    2   21.04.2020 16:29    2

Ответы
rororo5209 rororo5209  13.10.2020 14:49

C#

using System;

namespace ConsoleApp1

{

   class Program

   {

       static void Main(string[] args)

       {

           int n;

           bool b = false;

           Console.Write("Введите n: ");

           n = Convert.ToInt32(Console.ReadLine());

           int[] A = new int[n];

           Console.WriteLine("Введите массив: ");

           for (int i = 0; i < n; i++)

           {

               A[i] = Convert.ToInt32(Console.ReadLine());

               if (A[i] == 30) b = true;

           }

           Console.WriteLine("В массиве "+(b ? "есть" : "нет")+" числ"+ (b ? "о" : "а") + " 30");

       }

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика