Написать программу на яп паскаль: из чисел от 10 до 99 вывести те, сумма цифр которых равна s ( чтобы в программе были формулы по нахождению p1 и p2 и чтобы программа была выполнена через операторы div и mod,желательно с объяснением

averkin07 averkin07    1   20.03.2019 22:06    3

Ответы
timofeevaanyut timofeevaanyut  26.05.2020 10:50

var k,s, p1, p2 : integer;

begin

write('s = ');

readln(s);

for k:= 10 to 99 do

begin

p1:= k div 10;

p2:= k mod 10;

if p1+p2=s then writeln (k);

end;

end.

Пример:

s = 12

39

48

57

66

75

84

93

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы