Написать программу на яп паскаль для вычисления площади треугольника по его сторонам ab, bc, ca (формула герона). программу написать на 13 строк.

BlackCat169958 BlackCat169958    3   01.10.2019 19:30    1

Ответы
Sweetkristina Sweetkristina  09.10.2020 10:13

//PASCAL ABC.NET

var

 s, p, ab, bc, ca: real;

begin

 read(ab, bc, ca);

 p := (ab + bc + ca) / 2;

 s := sqrt(p * (p - ab) * (p - bc) * (p - ca));

 writeln(p, #10, s);

end.


 

ПОКАЗАТЬ ОТВЕТЫ
irina030270 irina030270  09.10.2020 10:13

Ровно 13 строк:

program Geron;

var ab,bc,ca,p: real;

begin

writeln('Определение площади треугольника по теореме Герона');

write('Введите сторону треугольника AB: ');

readln(ab);

write('Введите сторону треугольника BC: ');

readln(bc);

write('Введите сторону треугольника CA: ');

readln(ca);

p:=(ab+bc+ca)/2;

writeln('Площадь треугольника равна ',sqrt(p*(p-ab)*(p-bc)*(p-ca)):0:3)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика