Написать программу на ! выбрать из текста слова в которых первая буква совпадает с последней, слова в тексте разделены пробелами

lena1700 lena1700    1   31.07.2019 04:10    1

Ответы
dashamazurkevi dashamazurkevi  31.07.2020 23:37
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('Введите текст:');
  Writeln('Слова, в которых совпадают первая и последняя буквы:');
  s.ToWords.Where(x->x[1]=x[x.Length]).Println(NewLine)
end.

Тестовое решение
Введите текст: космос азбука     баобаб  импульс озеро  довод  конец
Слова, в которых совпадают первая и последняя буквы:
азбука
баобаб
озеро
довод
ПОКАЗАТЬ ОТВЕТЫ
ОливияСэм ОливияСэм  31.07.2020 23:37
//Free Pascal 2.6.4

uses
  strutils;

var
  s, t: string;
  i: integer;

begin
  write('Введите текст: ');
  readln(s);
  writeln('Найденные слова: ');
  for i := 1 to WordCount(s, StdWordDelims) do
  begin
    t := ExtractWord(i, s, StdWordDelims);
    if t[1] = t[length(t)] then writeln(t);
  end;
  readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика