Написать программу: на вход программы поступает неизвестное количество чисел целых, ввод заканчивается нулём. найти максимальное из введённых чётных чисел. python.

andreyyazyninp0875c andreyyazyninp0875c    2   16.09.2019 17:32    88

Ответы
VASILIEVAALEXANDRA VASILIEVAALEXANDRA  07.10.2020 20:15

list_number = []    # Создали список, сюда заносим числа.

number = int(input())   # Вводим число

while number != 0:    # Проверяем на равенство число нулю

   list_number.append(number)    # Добавляем число в список

   number = int(input())   # Вводим след.число

if list_number: # Если список не пуст

   # Фильтруем список(возвращаем список только с четными числами) и выбираем максимальное

   result_number = max(list(filter(lambda x: x % 2 == 0, list_number)))    

   print("Result: {0}".format(result_number))  # Выводим результат

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика