Написать программу на с++!
в данной строке удвоить все цифры и малые латинские буквы.

тса2 тса2    1   29.11.2019 16:44    2

Ответы
Nastyusha222 Nastyusha222  10.10.2020 17:13

#include <iostream>

#include <string>

using namespace std;

bool isb(char t)

{

bool f=false;

string dic="1234567890";

for(int i=0;i<dic.size();i++)

if(dic[i]==t)

return !f;

return f;

}

int main()

{

string s;

int i=0;

getline(cin,s);

while(i<s.size())

{

if(isb(s[i]))

{

s.insert(i,1,s[i]);

i++;

}

i++;

}

cout<<s<<endl;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика