Написать программу на С++ с любым из циклов. Задачи:
1) Каждый день в огороде созревают огурцы по 5 штук. Сколько будет огурцов через месяц?
2) На изготовление ювелирного изделия требуется 5 граммов золота. Сколько Украшений получиться из 3037 грамм?

Вазген228 Вазген228    2   05.03.2021 16:47    1

Ответы
Uknowmyname Uknowmyname  04.04.2021 16:50

1)

#include <iostream>

using namespace std;

int main()

{

   cout << 5 * 30 << endl;

   return 0;

}

2)

#include <iostream>

using namespace std;

int main()

{

   cout << 3037 / 5 << endl;

   return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
машана1 машана1  04.04.2021 16:50

#include <iostream>

using namespace std;

int Vegetables(int month)

{

int cucumbers = 0;

for (int i = 0; i < month; i++)

{

 cucumbers += 5;

}

return cucumbers;

}

int decoration(int gold_amount, int gold_per_decoration)

{

int decor = 0;

while (gold_amount > 0)

{

 decor++;

 gold_amount -= gold_per_decoration;

}

return decor - 1;

}

int main()

{

setlocale(LC_ALL, "rus");

int month = 30, gold_amount = 3037, gold_per_decoration = 5;

 

cout << "В месяц, длинною в 30 дней, созревает " << Vegetables(month) << " огурцов" << endl;

cout << "Из " << gold_amount << " грамм золота, можно получить " << decoration(gold_amount, gold_per_decoration) << " украшений" << endl;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика