Написать программу на с программа, которая переводит заданое число из восьмиричной системы в пятиричную

tanusik32 tanusik32    3   13.09.2019 23:50    3

Ответы
DiankaTokmashova DiankaTokmashova  07.10.2020 12:57
Замечание: контроль правильности ввода не выполняется.
#include <stdio.h>

int main(void) {
  int a_8, a_10, a_5, b, c;
  printf("Введите число в восьмеричной системе счисления: ");
  scanf("%d",&a_8);
  b = a_8;
  a_10 = 0; c = 1;
  while (b>0) {
    a_10 += c*(b % 10);
    c *= 8;
    b /= 10;
  }
  b = a_10;
  a_5 = 0; c = 1;
  while (b>0) {
    a_5 += c*(b % 5);
    c *= 10;
    b /= 5;
  }
  printf("%d(8) = %d(10) = %d(5)",a_8,a_10,a_5);
  return 0;
}

Пример:
Введите число в восьмеричной системе счисления: 2014
2014(8) = 1036(10) = 13121(5)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика