написать программу на С++. Пользователь вводит число а. Нужно, чтобы программа определила положительно ли число, если да, то: 1) посчитать сколько разрядов в этом числе;

2) определить каких разрядов больше: со значением от 0 до 4 или от 5 до 9.

Кет1235 Кет1235    3   29.10.2020 23:07    3

Ответы
Mani2106 Mani2106  28.11.2020 23:08

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "Russian");

string a;

cin >> a;

if(stoi(a)>=0) {

cout << a.length() << " разрядов";

} else {

cout << "Wrong data";

перефразировать вторую часть задания, исправлю. Какое значение?

}

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика