Написать программу на с++ . найти сумму элементов последовательности b1, , b15 , расположенных правее последнего отрицательного элемента и номер этого элемента.

Churikowao2004 Churikowao2004    3   28.05.2019 15:00    3

Ответы
ego1917 ego1917  26.06.2020 07:51
#include <iostream>

using namespace std;

int main()
{
    int a[15];
    int i = 0;
    int sum = 0;
    for (; i < 15; i++)
        cin >> a[i];
    for (i = 14; (i != 0) && (a[i]>0); i--) 
        sum += a[i];   
    cout << "i = " << i+1 << endl;
    cout << "summa = " << sum << endl;
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика