Написать программу на с++найти количество четных цифр заданного натурального числа n

Амина9505 Амина9505    3   03.06.2019 09:52    5

Ответы
fakt007723 fakt007723  03.07.2020 19:27

#include <iostream>

#include <locale.h>

using namespace std;

int main()

{

setlocale(0, "Russian");

unsigned int n;

unsigned short int s = 0;

cout << "Введите натуральное число N:" << endl;

cin >> n;

do {

 if ((n % 10) % 2 == 0)

  s++;

}

while ((n /= 10) != 0);

cout << "Количество чётных цифр числа: " << s << endl;

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика