Написать программу на с++. написать подпрограмму, которая находит максимальную цифру заданного числа и выводит её на экран.

Zyherpopentruher007 Zyherpopentruher007    2   15.09.2019 01:50    4

Ответы
nigina8807 nigina8807  07.10.2020 15:51
#include <iostream>
using namespace std; 

void mxd(int n) {
    int k,mx=0;
    do {
       k=n%10; n/=10;
       if (k>mx) mx=k;
    }
    while (n>0);   
    cout<<mx<<endl; 
}    

int main() {   
    int n;
    cout<<"number: ";  cin>>n;
    mxd(n);
    system("pause");
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика