Написать программу на с++, используя функции. найти наименьшее общее кратное четырех заданных натуральных чисел.

5класс75 5класс75    1   30.09.2019 20:30    3

Ответы
extysq3000 extysq3000  17.08.2020 01:54

#include <iostream>

#define _ std::

int NOD(int a, int b){

return (a == 0) ? b : NOD(b%a, a);

}

int NOK(int a, int b) {

return (a*b) / NOD(a, b);

}

int main() {

int a, b, c, d;

_ cin >> a >> b >> c >> d;

_ cout << NOK(a, NOK(b, NOK(c, d))) << _ endl;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика