Написать программу на с++ 3. известен факториал числа (вводится с клавиатуры). найти это число.

Андрей22111111 Андрей22111111    3   09.09.2019 14:20    6

Ответы
Piragovicch Piragovicch  07.10.2020 03:20
1.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    n = 0;
    p = 1;
    while (p<f) {
    n++;
    p*=n;
    }
    if (p==f) cout << n;
    else cout << "Ошибка ввода";
    system("pause");
}

2.
#include <iostream>
using namespace std;

int main()
{
    int f, n, p;
    cin >> f;
    p = 1;
    for (n=1; p<f; n++) p*=n;
    if (p==f) cout << n-1;
    else cout << "Ошибка ввода";
    system("pause");
}

Пример:
120
5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика