Написать программу на Python которая напечатает все возможные комбинации слов (от A до Z) в консоль. Именно все возможные, вот прямо всё что можно написать используя только 4 символа английского алфавита

25424446645 25424446645    3   17.06.2021 19:06    1

Ответы
Мэрия777 Мэрия777  17.06.2021 19:10

a = 'A , B , C , D , E , F , G , H , I , J , K , L , M , N , O , P , Q , R , S , T , U , V , W , X , Y , Z'

a = a.replace(',', '')

a = a.replace(' ', '')

for k in a:

   for l in a:

       for m in a:

           for n in a:

               print(k + l + m + n)

насчет повторов не уверен, если будут, то:

l = []

a = 'A , B , C , D , E , F , G , H , I , J , K , L , M , N , O , P , Q , R , S , T , U , V , W , X , Y , Z'

a = a.replace(',', '')

a = a.replace(' ', '')

for k in a:

   for l in a:

       for m in a:

           for n in a:

               l.append(k + l + m + n)

l = set(l)

for i in l:

   print(i)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика