Написать программу на ПАСКАЛЕ. Задача 1
Напишите программу, которая в последовательности натуральных чисел находит наименьшее число, оканчивающееся на 2. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Гарантируется, что в последовательности есть хотя бы одно число, оканчивающееся на 2. Программа должна вывести наименьшее число, оканчивающееся на 2.
Задача 2
Напишите программу, которая в последовательности натуральных чисел находит наибольшее число, оканчивающееся на 5 не кратное 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Гарантируется, что в последовательности есть хотя бы одно число, оканчивающееся на 5 не кратное 3. Программа должна вывести наибольшее число, оканчивающееся на 5 не кратное 3.
Задача 3
Напишите программу, которая в последовательности натуральных чисел находит разность между максимальным двузначным и минимальным трехзначным числами. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Гарантируется, что в последовательности есть хотя бы одно двузначное и одно однозначное число. Программа должна вывести одно число - разность между максимальным двузначным и минимальным трехзначным числами.

МиленаГригорьева25 МиленаГригорьева25    2   13.12.2020 12:14    21

Ответы
tatgomer tatgomer  13.12.2020 12:20
я в подвале маньяк держит меня плажу1ья ааа тыза рудойн запомни номер 123 ты не умрёшь я тебя мрасц я матвей
ПОКАЗАТЬ ОТВЕТЫ
gta1234657 gta1234657  13.12.2020 12:20

15.2 Решение

 

var N, a, num: integer; begin

N:= 0;

num:= 0;

readln(a);

while a<>0 do begin

num:=num+1;

if (a mod 2 <> 0) and (a mod 3 = 0) then N : = N + 1;

readln(a);

end;

writeln(num); writeln(N);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика