Написать программу на паскале: в целочисленном одномерном массиве из n(n< =50)элементов.найти номера элементов кратных 3.если таких элементов нет, то сообщить об этом.массив заполнить вручную.

serikovvlad19 serikovvlad19    3   22.05.2019 09:20    2

Ответы
ВасилийПупкин227 ВасилийПупкин227  01.10.2020 06:34

Program Natasha1925;
uses crt;
const n=50;
var
 a:array[1..n] of integer;
 tri:array[1..n] of integer;
 nom,i: integer;
  begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  nom:=0;
  for i:=1 to n do
  begin
    write('Введите ',i,'-e число ');
    readln(a[i]);
    if a[i] mod 3 = 0 then
      begin
        nom:=nom+1;
        tri[nom]:=i;
      end;
   end;
  if nom = 0 then
      writeln('Элементов, кратных 3, нет!: ')
    else
      begin
        writeln('Номера элементов, кратных 3: ');
        for i:=1 to nom do
          begin
            write(tri[i],' ');
          end;
      end;
   writeln();
end.

ПОКАЗАТЬ ОТВЕТЫ
masha859689 masha859689  01.10.2020 06:34

uses crt;
var
  a:array[1..50] of integer;
  i,n,k:integer;
begin
  clrscr;

  k:=0;
  write('Введите количество элементов массива'); read(n);
  writeln('Введите массив:');
  for i:=1 to n do
    read(a[i]);
  write('Номера элементов, кратных 3:');
  for i:=1 to n do

    if (a[i] mod 3=0) then
    begin
      k:=k+1;
      write(i,' ');
    end;
  if k=0 then write('Таких элементов нет.');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика