Написать программу на паскале у меня x яблок.. яблоко стоит e $, курс доллара к рублю p рублей за доллар.. и y человек.. сколько нужно яблок чтобы каждому человеку досталось по 1.66 яблока, или больше, количество яблок должно быть кратно 5 (недостающие яблоки можно докупить) и сколько рублей нужно будет потратить

nikitosik1296 nikitosik1296    3   27.08.2019 16:40    2

Ответы
katyanosa katyanosa  05.10.2020 23:03
Var
   X,Y,K:integer;
   E,p:real;
Begin
Write('Сколько яблок в наличии: ');ReadLn(X);
Write('Сколько человек: ');ReadLn(Y);
Write('Сколько долларов за одно яблоко: ');ReadLn(E);
Write('Сколько рублей за один доллар: ');ReadLn(p);
if X mod 5 <> 0 then K:=X+5-(X mod 5)
else K:=X;
While K/Y<1.66 do K:=K+5;
WriteLn('Требуемое количество яблок: ',K);
WriteLn('Столько яблок придётся докупить: ',K-X);
WriteLn('Стоимость докупленных яблок: ',(K-X)*E*p:0:2,' руб.');
End.

Пример:

Сколько яблок в наличии: 1
Сколько человек: 3
Сколько долларов за одно яблоко: 50
Сколько рублей за один доллар: 0.05
Требуемое количество яблок: 5
Столько яблок придётся докупить: 4
Стоимость докупленных яблок: 10.00 руб.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика