Написать программу на паскале
рассматривается множество целых чисел, принадлежащих отрезку [200; 9120], которые делятся на 8 и не делятся на 7, 11, 17 и 19. Найдите количество таких чисел и минимальное из них. В ответе запишите два числа через пробел: сначала количество, затем минимальное число.

tanyaoganesova tanyaoganesova    1   19.04.2020 16:45    34

Ответы
чурка2829 чурка2829  13.10.2020 11:55

var cnt,min,i: integer;

begin

min:=0;

cnt:=0;

for i:=200 to 9120 do

 begin

 if (i mod 8 = 0) and (i mod 7 <> 0)

 and (i mod 11 <> 0) and (i mod 17 <> 0)

 and (i mod 19 <> 0) then  

   begin

   if (min=0) then min:=i;

   cnt:=cnt+1;

   end;

 end;

writeln(cnt,' ',min);

end.

   

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика