написать программу на Паскале Нужно до завтра. 1)Напишите программу, которая в последовательности натуральных чисел определяет максимальное нечётное число.

Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется нечётное число. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное нечётное число.

2)Напишите программу, которая в последовательности натуральных чисел определяет сумму чисел, оканчивающихся на 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — сумму чисел, оканчивающихся на 4.

lol1046 lol1046    2   13.01.2021 20:11    2

Ответы
Diron2004 Diron2004  13.01.2021 20:20

1)var n,a,i, max:integer;

begin

 writeln('ведите кол-во чисел');

 read(n);

 max:=0;

 for i:=1 to n do

 begin

   writeln('введите очередное число');

   read(a);

   if (a mod 2=1) and (a>max) then max:=a;

 end;

 writeln(max)

end.

2)var n,a,i, k:integer;

begin

 writeln('ведите кол-во чисел');

 read(n);

 k:=0;

 for i:=1 to n do

 begin

   writeln('введите очередное число');

   read(a);

   if  a mod 10 = 4 then k:=k+a;

   end;

   writeln(k)

   end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика