Написать программу на паскале. найти 11 последовательных натуральных чисел, сумма квадратов которых сама является квадратом натурального числа.

ArtemDigue ArtemDigue    2   16.09.2019 16:50    2

Ответы
zaj2015 zaj2015  07.10.2020 20:07
//PascalABC.NET
//Версия 3.3, сборка 1611
begin
var t: real;
var i:=1;
while true do
begin
t:=range(i,i+10).Select(x->x*x).Sum();
if (frac(sqrt(t))=0) then break;
inc(i);
end;
range(i,i+10).Println();
end.
ПОКАЗАТЬ ОТВЕТЫ
nikitazaharov28 nikitazaharov28  07.10.2020 20:07
Var
  i,n,s:integer;

begin
  n:=1;
  while true do begin
    s:=0;
    for i:=n to n+10 do s:=s+i*i;
    if s=Sqr(Trunc(Sqrt(s))) then break;
    n:=n+1
    end;
  Write('Сумма квадратов чисел на интервале [',n,';',n+10,'] = ');
  Writeln(s,' = ',Trunc(Sqrt(s)),'^2')
end.

Результат
Сумма квадратов чисел на интервале [18;28] = 5929 = 77^2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика