Написать программу на паскале. напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму всех чисел, которые кратны 6 или 11.

sashabiryukova sashabiryukova    1   28.05.2019 07:10    5

Ответы
cashpass8754 cashpass8754  25.06.2020 17:23
Uses crt;
var a,sum:integer;
begin
     sum:=0;
     repeat
           read(a);
           if (a mod 6=0) or (a mod 11=0) then sum:=sum+a;
     until a=0;
     writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика